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IPMR concepts
IPMR is an application that has been developed to assist BTO ringers and nest
recorders to enter, manage and submit ringing and nest record data to BTO HQ.
IPMR holds its user’s data in a database.  This database holds both ringing and nest
recording data.  Submissions to BTO HQ for ringing, CES, RAS and nest recording
are made independently of each other.

Multiple databases
are supported

IPMR can support multiple databases.  The use of more than one database is
usually required for ringers who use both their own rings and also those of a
partnership or group thus requiring the records to be kept separate.  For nest
recording in a ringing partnership or group normally all Nest records would be
entered into one IPMR database. This need not be the one fom which the Ringing
records are submitted.

IPMR concepts for Ringing Data

Information on Ring
Series and captures
can be exchanged
within ringing
groups

The concept behind IPMR is that the prime copy ringing data for an individual or
group is maintained within one IPMR database.  The prime copy of ringing data is
the authoritative copy - the one from which data are sent to BTO HQ.  There are a
number of facilities within IPMR to support this including: the checking and
automatic setting of record types based on records already within IPMR; the
maintenance of the usage of rings within series and the automatic generation of
submission sequence numbers.

In a group situation multiple people can enter capture data; it is recommended that
this be on the basis of responsibility for discrete series of rings.  The series need not
be the full series as received from BTO HQ, but could be perhaps a set of , say, 100
rings out of a series of 1,000.  The allocation of rings can be managed through the
Ring Series facility.  The Ring Allocation Splits function aids the entry of ring
series which need to be split for allocation for example to ringing group members
(they are also used for an auto ring series add facility when importing capture
records).

Use more than one
database if
appropriate.

Someone who enters ringing captures for (1) their own rings, (2) for another ringer
and (3) for a ringing group should do so in three different database files.  See the
File > Select > Database function about creating a new database file.  You should
not have a separate database for each year.

IPMR is not really designed to hold personal records of birds ringed on someone
else’s rings, e.g. on a ringing course.  It can be done, but these captures should
certainly be held in a separate database from one used to submit captures to the
BTO.

IPMR automatically
manages which
records have been
submitted to BTO
HQ

The submission of records to BTO HQ is done on a different basis to B-Ring.
Because IPMR holds all records and allows them to be automatically managed
there is no need to control which ring series to submit and which not to; this is
handled by IPMR automatically.  When a submission file is created ALL records
ready for submission are selected.

IPMR concepts for Nest Recording
All nest records for an individual or group for multiple years are held in a single
IPMR database.  IPMR doesn’t have any facilities to allow multiple people to enter
nest record data and for it to be consolidated into one IPMR database.

Each nest has a unique sequentially numbered Nest Record Number in the database;
this number cannot be changed.
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Places and subsites
hold default habitat
and nest information
to aid nest data entry

Manage your
portfolio of Nest
Boxes

Places hold geographic information such as grid reference and county and should
be defined before creating any nest records; these represent a piece of woodland, an
area of moorland, or a park for instance.You will often find that there is nest
information that is common across nests.  This can be because the habitat at a site is
the same for large areas or it can be common across years for regularly used nest
sites or where Nest Boxes are used.  You can define subsites and Nest Boxes within
IPMR.

Once set up Subsites can be selected directly from the Nest form or can be linked to
a Nest Box.

Nest Boxes are a key feature of IPMR.  When a Nest Box is set up in IPMR it is
linked to a Nest Box Type which hold information about its size, type and the
material it is made from.  Nest boxes can be linked to a Subsite for habitat
information. A variety of information is held Nest box details.  When a Nest is
created a Nest Box code can be selected.  If the information above has all been
entered when the Nest Box was defined then the Nest Box Type, Subsite, Habitat
and other information such as nest height and orientation are copied into the Nest
record.  Alternatively these details can be entered directly into the Nest record.  (If
Nest Boxes are not identified individually then there is no need to set any up.)

Both Subsites and Nest Box details can hold a grid reference.  This can be your
own local reference, but if it this is an OS 6 figure grid reference such as NZ372567
then it will be copied into a nest record when selected.

Multiple submissions can be made in a given year, but it is expected that generally
one submission will be made per year.

B-Ring and IPMR compatibility
Import your old
B-Ring Data

B-Ring RDF files or standard Submission format files created by B-Ring can be
imported into IPMR.  See Importing Captures below.

The B-Ring BTOPL.TAB file can be imported into IPMR from the Import/Export
Control Information.  See the Place codes section under Starting IPMR for the first
time below.

Using IPMR within Partnerships and Groups

Exchange ringing
data within your
group or partnership

Operation as part of a group, partnership or when other people such as C-permit
holders are using the rings requires the exchange capture records.  The Ringing
Secretary should have the Group’s IPMR Database.  Other group members can use
IPMR (or B-Ring) to send in Submission  (or RDF or comma delimited) files.  The
exchange of Place details, Subsites, Observers and Ring Series is also
recommended.  These can be transferred from the Group’s Database to members
databases, which is suggested for Ring Series, or vice versa, which is more likely to
add new Place records.  This is accomplished using the Control > Import and
Export functions available under the Control menu item.  See the Ring Series
section later in the guide for more information on allocating Ring Series out to
group members.

Group members should use their own name and permit number not that of the
group.

As a result of all this it is recommended that the person who collates capture
records for submission to BTO HQ uses IPMR, but those who collect and enter the
data can use either B-Ring or IPMR.  There are benefits in having IPMR used by all
members of a group such as the exchange of Ring Series information, but this is not
critical.

Little things that you should know
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• There are often many ways of doing a particular task wihin the Windows
environment.  For the purpose of filling in data into forms, which is most
of what you are doing with IPMR, it is recommended that you use the
TAB key to move from field to field.  Sometimes an extra field (or box)
will appear depending on your response in the previous field or the
cursor will jump to another field missing out ones that aren’t appropriate.
The mouse is most useful for tick boxes and drop down menus.

 Windows Date and
Time formats

 • The Regional settings (in Control Panel) for short dates must be set to
English (British) or English (United Kingdom) and the year component
must be present.  This ensures that date format are day, month and year
e.g. dd/MM/yy.  Four digit dates e.g. dd/MM/yyyy and period seperators
e.g. dd.mm.yy are also acceptable.  Also the Time display settings (also
in Regional Settings) can cause problems.  If IPMR won’t start then set
the Time style to be HH:mm:ss.  If it is already set to these values then
re-enter dd/MM/yyyy and for the time and re-enter or re-select
HH:mm:ss as the Time Style and (without touching any of the other
settings) click the Apply button.  IPMR will not start unless these
settings are correct.

  • There is an Options form under the Control menu item.  This sets up a
number of useful things including the Current Year that data is being
entered for.  Take a look at the form and its accompanying help

 Just type in the day
and month for dates

after setting the
Current Year

 
Don’t forget the F1

and Esc keys

 • When entering data into some fields, particularly numeric ones,
something like __._  is often displayed.  This shows the format of the
entry required; in this case a number with one decimal place.  To enter
the data type the number, e.g. 21.1, into the field.  Also just 1.1 can be
typed into the field; this will initially look like 1_.1, but when the next
field is moved to then the number entered will look like 1.1 as might
have been expected.

• Help for a form can always be viewed by just pressing the F1 key

• Pressing the Esc key will Undo the last edit.  Pressing it twice will undo
all changes made to the record

• If IPMR goes into an error loop then using the Ctrl-Shift-Q key
combination will try and shut down IPMR to save turning the PC off!

  

Creating backups of the database
 
Ensure that your
data is safe

  As with all valuable information, the data held in the IPMR database needs to be
looked after.  Periodic backup copies of the database(s) should be made as
insurance against software or hardware failure.  Having a recent backup will help to
reduce the impact of such a failure.  Having multiple backups is highly
recommended because if the database is unknowingly corrupted and a backup is
made when you leave IPMR then the backup will be corrupted too.  Backups are set
up from the Control/ Options menu item.  The use of the PKZip backup option to a
diskette is recommended as PKZip backups can hold in excess of 20,000 records
per diskette and PKZip will automatically span multiple diskettes if required. (This
facility does not require the use of a Zip Disk!)

   Creating multiple backup sets can be achieved quite simply.  A Backup Set is
composed of one or more diskettes.  Say that it is decided to have three backup sets.
Each set can be used in turn: backup set number 1 after your first session, set 2 after
the next, set 3 next time, and then overwrite set 1 again after the fourth session.
Consider taking one copy to be held “off-site” well away from the computer that
holds the prime data so that major damage to a building will not damage the
backup.

  

Mapping Tool Integration
 From the Capture Selection and Processing facility DMAP or VersaMap files can
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be generated and managed.  DMAP or VersaMap can then use these output files to
show point positions or movements.  Only more recent releases of DMAP will
support movements. 

Standard Reports
 IPMR has many standard reports available.  If you can’t find a report use Help
Search and enter “Report” .  The reports include:

  • Place summary details
• Ring series usage
• Ring stocks
• Available rings report
• Costs of rings report
• Ring costs by observer
• Capture history
• Recovery history
• Recoveries
• No original ringing record
• Capture details summary
• Cross-tabulation for captures
• Captures submissions
• Outstanding Controls

  

Report Manager
 There is also an ad-hoc reporting facility available using the report manager.  Using
this facility records can be selected from IPMR tables or existing queries and
reports created.  The fields for the reports, groupings and sort orders for the data
can be selected and row and column headings can be entered

  

Your own copy of Microsoft Access ?
 In order to allow you to use all of the features and functions of IPMR mentioned in
this guide a run-time version of Access is installed when IPMR is installed. If you
have your own copy of Access at versions 2, 95, 97 or later then you can use it for
analysis and reporting functions that are not provided by IPMR already. See
Integration with your own copy of Microsoft Access (Page 3)
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 IPMR Functions
 

 

 

 
Follow the help
screens to set up
IPMR right first
time

 

General
 IPMR requires the Owner information to be added when an IPMR database is first
used.  This is information such as your name, permit number and/or nest recorder
observer code. 

 When IPMR is started for the first time some Help screens will be popped up
automatically. 

 At the bottom of the help screens for the key features of IPMR that are required to
set up IPMR are sections headed ‘What next if you are setting up IPMR:’.  These
will lead the user through the other things that you need to do to start using IPMR.
If a help screen is accidentally closed then go back to the main ‘blue’ IPMR screen
and press F1 and the last help topic will be re-displayed.  Some of the information
contained in this help flow is given in the following sections:

  
Owner 
 IPMR requires the Owner information to be added when an IPMR database is first
used.  This is information such as individual, partnership or group name, permit
number and/or nest recorder name and observer code.  The permit number or
observer code must be added before ringing capture or nest record data can be
added to IPMR..

 You will be prompted for this automatically or to go back and view or change the
information click on the menu Control > Owner Details.

  If you are a nest recorder and not a ringer, but pulli in any of your nests are ringed
then PLEASE do enter the details of the ringer or group involved in the Ringer
fields (They will give your their permit number).  If there is more than one ringer or
group ringing your birds then either enter one of the details of dummy values such
as ‘Ringer’ and ‘999’.  This will enable you to enter pulli (and/or adult) capture
information including ring numbers for your nests; this is most valuable to the
BTO.

 

 

 

 

 

 Make sure that you
set the IPMR
Options correctly

 
IPMR Setup and Options
 There are a number of options that need to be setup in order to make best use of
IPMR’s facilities.  To view or change your options Click on the menu Control >
Options.

 Folders/Directories can be set up as required.  During the installation the
application folder (c:\ipmr by default) where IPMR and its associated files
reside will have been chosen.  The Data folder is where the IPMR database(s)
are held.  Other folders to help manage importing and exporting information can
be set too.  These folders can be on another drive (e.g. a drive that holds only
data to ease the making of backup copies of files).

 Backup options referred to above are set from the Options form.

 Current Year is the way the IPMR avoids having to key in a four digit year
with every date entered.  Normally it will be the calendar year for which
recording is being made, but it can be set to any previous year for entering
historical records.

 Default Country should be set to GB for Great Britain and Northern Ireland or
ER for Eire.  This is the default used when setting up Place codes (see below).

 Export Format is the format (comma delimited, WK1 or Excel) used to export
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information from IPMR in particular from Captures and Nest Selection and
Processing functions. 

 Capture Update Confirm option of Yes will prompt before each Capture
record being entered is saved (as for B-Ring).  A setting of No will stop this
prompt appearing.

 Return Key behaviour This option allows you to set whether pressing the
Return key will take you to the next field or next record.

 Other options are available.  Go to the Options form and click on the help
button to get a complete overview of the options.

 The next thing that
you will want to do
is to try entering
some data, but there
are a few things that
need to be set up
first:

 

 

 

 
Observers 
 Observers, are optional, but are required for allocating ring series to, assigning
processors’ or wing measurers’ initials to captures and to assign Nest Records to.
They are also used for reporting purposes e.g. for someone’s ringing or training
totals for the year.

 Click on menu Control > Observer Details to view, enter new or update Observer
information.  Go to the last line (if there are already observers present) of the list
and type in the name of the observer/ringer.  Press TAB and enter the initials
normal used on ringing sheets for this person.  Press TAB again and enter their
ringing permit number if appropriate.  Press TAB again to reach the Other Observer
check box and TAB again to enter a new name, or ENTER to exit the form.  For
now don’t worry about Other Observer checkbox - see Help for further information.
Observers can be deleted later only if they have no records associated with them in
the database.

 

 

 

 Import your B-Ring
BTOPL.TAB file

 
Place codes - 1km squares
 Places codes are references to the 1km squares (in GB, NI and Eire) at which
ringing or nest recording takes place.  These must be entered.  They can be up to 6
characters in length, but if you need to stay compatible with B-Ring should be kept
to three charaters in length.  Registered site codes are also entered here; they can be
the same as or different to the IPMR place codes (and there can be multiple Place
codes sharing a registered site code if required).  This is done using the Places form
under the menu Control > Places > Own Places Details.  A list of all of your Place
codes will be presented.  As shown in the screen shot below this list can be sorted
as required.  Click on Create for a new Place code; enter the new place code into
the field on the pop-up window and click OK.  Click Edit to view or update a place.

 The ‘Ringing’ check box must be set in order to use the Place code for ringing
captures and the ‘Nest Recording’ check box for use with Nest Records.  These are
automatically set when entering Places manually or on import based on whether
there are permit number or nest recorder codes entered on the Owner details form.

 Enter your grid reference first; this will set the default list of counties/regions to
which IPMR thinks you should select.  If the list doesn’t include the right county
then select ‘Full List’ from the drop down and all of them will be displayed (also
please inform the BTO of the omission so that it can be corrected).

 Enter the Registered site code if there is one and it has been registered with the
BTO.  Select Coastal or Inland in order to support the Age Specific Totals list.

 The defaults panel at the bottom of the form will put the values shown into your
capture or nest records when you select a Place code for them.  They will not be
changed retrospectively if, for example, the Place’s habitat changes.

 If CES ringing occurs at the Place then Click on the CES check box.  Enter the CES
site code in the field (box) that appears.  In order to enter ringing details at a Place
with the CES check box selected during the April to September period a Ringing
Session must have been set up (see later) or the CES start and stop years must have
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been set to exclude entry of, for example, historical data.  These years are set by
entering them on the pop-up form displayed by clicking the CES Details button
(which is onlly displayed when the CES checkbox is selected).

 The Owner’s Place checkbox should normally be left set.  If not it becomes an
“Others’ Place” which are used for Recovery and control sites.

 If there is an existing B-Ring BTOPL.TAB file or another IPMR user has entered
some of your Places then they can be imported from the Control> Import/Export>
Import Control Information.  The BTOPL.TAB file must be first copied into the
Import Path directory or folder. (Place details can also be shared among IPMR
users using the import and export functions).
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 Ringing
  

 Ringing subsites
   Ringing subsite details hold default habitat and capture methods for regularly used

sites or nets for general and in particular for CES ringing.  Subsites are set up
within a Place so a Place code should be selected first. 

 The values shown are defaults and will override those set for the assocaited Place.
If the Place is set for CES then the Subsite will display a selection for whether the
net (subsite code) is a standard or additional net.

 

 Manage your ring
series and keep track
of their costs too

 
 Ring Series 
 IPMR automatically keeps a record of the usage of Ring Series, allows the
management of the allocation out of rings within a group and provides some ring
cost reporting. 

 If IPMR is to be used for ringing data then Ring Series will need to be entered.
They can be entered in advance or added while manually entering captures or
during the import process.  Adding in these latter cases can be done using the Ring
Series form from the menu or, if series splits have been entered in to the Ring Size
Information function, a prompt will offer to add a series automatically.

 Take a look at the the Ring Size Information form using menu Control > Ring
Series > Ring Size Information and set your default ring size allocation value that
you would like IPMR to use as a default ring series length when creating ring
series.  Note the Last Ring Number user column which will be blank if you are a
new user; this is used to allow IPMR to set the next ring number when entering
ringing Captures when a species that takes a given ring size is entered.

 Manually creating Ring Series is done from the menu Control > Ring Series> Own
Ring Series.  The first ring and the length of string should be entered.  All other
fields are optional.

 Ring Series can be “allocated” to group members or others who use rings.  This
allocation allows their use and submission status to be monitored.  If the Ring
Series are allocated then the Control Export file can be created for an individual in
the Observers table.  This allows a Ringing Secretary to send out new series of
rings and a diskette/email with a file allowing the ringer to load the series
information into their IPMR database.

 Some old ring series are not in the Ringing Unit’s validation file.  Rings in these
series cannot be used except if they are imported with the option that they are not to
be submitted; in this latter case the ring series are set up by the import function.

  
 Submission sequence number
 If data on disk submissions have already been made (using B-Ring or your own
program) in the calendar year that IPMR is first used then the Reset Submission
Sequence Number facility will need to be used to tell IPMR the last sequence
number used from Control > Submissions > Reset Last Submission File Number.

  
 Captures field setup

 

 Ease the burden of
new bird and retrap
captures data entry

  When entering capture records it needs to be as efficient as possible.  Because
IPMR holds all fields in its database (rather than just selected fields as in B-Ring)
there is a Field Setup facility.  This allows, within certain restrictions, the fields that
are displayed when entering data to be selected and tabbed through in a preferred
order.  Multiple setups for different types of ringing operation can be created.



Mark Cubitt          IPMR General Introduction Page 12

 The field setup is based on putting IPMR fields into one of three categories: Tab
order, View list and Hide list.

   Tab Order list Fields in the Tab Order list will appear on the Enter Capture
Details form and are the only fields that will be tabbed
through when entering information.  The order of fields in
the list determines the order that they will be tabbed through.
In the List style Enter Capture Details form it also
determines the order in which the fields are displayed. 

 View List Fields in the View list will appear on the Enter Capture
Details form, but will not be tabbed to when entering
information

 Hide list These fields will not be displayed on the Enter Capture
Details form.

   Select a field to be moved between lists so that it is highlighted and then click on
one of the button with horizontal blue arrows between the two lists involved.  The
field will then move between the lists.  Sometime it will take a partner field e.g.
Pulli Ringed and Alive.  The order of fields in the Tab order sequence list is
changed using a similar process except using the vertically aligned arrow buttons at
the left size of the form.

 The best strategy for using the Field setups will be developed by each user over
time.  Initially it may be easier to have all of the required fields in the tab order list.
However, when data entry becomes more familiar then fields for which the auto
repeat function is used (see Entering Captures below) can be put in the View list.
Once values are set up for the first capture of a data input session (using a mouse to
move between fields) this will save the extra tab key depressions required to enter
the data for the rest of a session’s captures.  Note that when tabbing out of the last
field in the Tab Order list the record will be saved and the next one opened.

  
 Constant Effort Sites

   Constant Effort Site (CES) ringing is supported by IPMR.  Captures are entered in
the normal way.  However, some additional information needs to be set up
specifically to support CES. 

• Place information (see above) includes an indication that a Place is used for
CES using the CES Checkbox and the CES Site Code.  The First and Last years
of a CES study can also be set (this is optional - if you don’t set them then all
years are assumed).

• Capture Subsites should  be set up for that Place for each net (whether standard
or additional).  If you need to exclude a net from CES reporting, e.g. when
doing a RAS study nearby in non-CES nets, this can be achieved using a subsite
code with the CES Exclude check box selected.

When importing B-Ring data that uses OWN, OWN2 or USER1 field to hold
net or additional net information the User defined import code conversions can
be used to convert these codes to IPMR Subsites.

• Ringing Session information is recorded in order set up visit numbers/codes for
CES reporting.  All mist netting visits during the CES season (from April to
August) must have a Ringing Session.  These can be either an CES visit (in
which case the visit code is numeric - from 01 to 12) or a non-CES visit (with
alphabetic codes).

In the example screen shot the visit details are not completed.  These are
optional, but can be used to create a CES submission report.

Captures cannot be entered for Places where CES ringing occurs during the
CES season without a Ringing Session recorded as either a CES or non-CES
visit.  The CES summary sheet report contains a column for Captures in CES
season without a session which should always have zero values as a check that
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all Ringing Sessions have been set up correctly.

The View Captures button can be used to display all (non-pullus) captures for
the session.  The subsite and its additional net or excluded net status are also
displayed.  Also in order to exclude individual birds from CES submission a
check box beside each capture can be clicked.

 Annual CES submission files and report can be created using the Constant Effort
Site Submission Function.

  
 Entering Captures

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Current Year is set
in Options 

 
Auto repeat copies
information from
one record to the
next

If you record each
ring series on a
separate sheet

 If you record all new
birds on the same
sheet

 

 

 
If you record retraps
and new birds on the
same sheet

 

 

  There are a number of other things that can be set up to aid the use of IPMR, but
this is the minimum.  If you want to try it out now you can go to the Captures/New
(form or list styles) to enter some captures.  You can use either style of form
depending on your personal preference; the Form style displays one record per
capture, the List style displays records in a spreadsheet-like manner.  The List style
shows records for only one day and avoids having to enter the date. (These records
can be deleted if you are just testing out IPMR using the Capture Selection and
Processing function by selecting all dates, selecting the record and pressing the
‘Delete’ key.)  

 Captures will normally be birds you trap yourself during normal ringing activities
and will as such usually be New birds or Retraps.  However, they can also include
birds that have been recovered by non-ringers, found dead or has been observed as
field sightings.  In these cases the appropriate record type will need to be selected.
There are 18 different Record types (not just N, C and R) so if you don’t know how
to use them (including recent changes to sightings record types) please use help and
search on “record types”.

 There are a number of facilities to aid the adding of records. Which of these you
employ depends, in part, on how you record data in the field – see below for some
examples. These include:

• To avoid the need to type in the year of Capture into records, the Current
Year is set in the Options facility.  This can be set to a previous year if
you wish to enter historical records. 

• Double clicking on the input fields for record type, ring number, species,
date and some other fields sets the auto repeat function.  This copies
information from one record to the next (or increments the ring number);
the fields’ background turns pale yellow in colour to show that auto
repeat is on for that field.  A number of fields are set this way by default.

• Ring numbers can be incremented using the auto repeat function
mentioned above for Record Type and Ring number.  This is useful if a
string of new rings is being entered.  

• If a mixed set of ring sizes for new birds the set the autorepeat to record
type only. IPMR keeps a note of the last ring used of each ring size so
don’t enter the ring number first and perhaps put the Ring field lower
down the tab order. When a species is entered then the next ring number
for the appropriate size is entered automatically.  This facility needs a
new-bird record type to be present and depending upon the species the
ring number may not be added until the age and/or sex are added.

• If you enter the ring number first IPMR automatically looks through
your database for previous records to set the record type for you.  This
will only work effectively if you have historical records in the database
of course
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 Use 2 or 5 character
species codes to
speed data entry

 

 Use the Full list
entry to change from
a ring size based
species list

 • In the species field a special facility allows the use of the BTO’s short
codes for common species e.g. “R.” for Robin or “SW” for Sedge
Warbler1. Full species codes can be used too.  The mouse can also be
used to select entries in drop down lists, but keyboard entry is faster if
you know the codes 

• The list of species codes to select from is based on ring size.  This means
that the number of letters in the species code that you mean to type is
minimised.  If you use a non-standard ring size for a bird or it is an
uncommon species then you can either enter the species code or select
the Full List entry in the Species list.  This latter option will extend the
list to all of the species available. (If it is still not one of these then you
will need to use the special ****1 species code for rarities.)

• You can enter the sex in the Age field e.g. 4F and the sex code will be
automatically moved to the Sex field for you..

To start entering Capture records using the List style form select from the menu bar
Captures > Enter Capture Details > List style.  This will present a form that
requests the required Captures Field setup (see above) and also the date for the List
style form (the date is not requested for the Form style).  Click on OK to continue.

The Captures Entry form will be displayed.  The cursor will usually be in the ring
number field.  Enter the ring number.  Unless it is a Control the ring should be part
of a ring series already entered into IPMR.  If you have not already added it then
rather than closing the Captures entry form the New Ring series can be added using
the Control > Ring Series >Own Ring series menu function as outlined above. 

Use the Tab key to move through the fields and enter data directly using the
keyboard.  For drop down lists then keyboard entry can be used with the list of
entries in the list being scanned as characters are entered so for example when
entering a Sedge Warbler only “se” need be entered as that is the only species code
starting with SE that takes an “A” ring. 

If you put in initials of a subsite code not already in the system, you will get a
message saying the text you enter must match an entry in the list.  Do not panic!
Use the drop down list to make the selection or if it really is a new observer or
subsite click OK and then use the menu Control > Capture Subsite (or Observers)
and create the new entry.  Close the Control information form and you can then
select the new entry back in the Captures form.

IPMR assumes that all birds are new birds unless you put in a ring number that is
already in the system or if it is not part of a Ring Series in the system.  If the ring
number is already in the system then IPMR automatically enters the species and the
other fields can be entered as normal.  If you don’t have older data in the system
(e.g. imported from B-Ring) then you will have to manually set the Record type
field to R. (If you enter retraps as a set then Auto-repeat can be set for the record
type field.)

Importing Captures
B-Ring RDF files, Submission file and comma delimited (CSV) files can be
imported into IPMR.  See Help within IPMR for more details about the CSV format
required.  The Control > Options function allows the Import directory to be set.
This could be the directory used to hold B-Ring information e.g. c:\bring\btodata\. 

Place (1km square) codes must be set up beforehand.  These can either be created
individually from the Control > Places function or imported from a B-Ring
BTOPL.TAB file or from Control Export files created by other IPMR systems for 

                                                          
1 The short codes can be found using the File > IPMR Table and Queries facility by Viewing the Species Data
table and looking for the column headed SSPEC.
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Auto Creation of
Ring Series

Continue until error
or Bypass error

options on Import

Old codes can be
converted to current

values

example those of other group members.

It is probably best if Ring Series have been set up before importing capture records,
but this isn’t required.  If a value is entered in the Split Into Series Of  field for a
ring size in the Control > Ring Series > Ring Size Information facility, then Ring
Series of this length will be set up automatically when a capture with an unknown
ring number of this ring size is encountered during an Import.

To import capture record select Captures > Import Captures from the menu.  Select
one of the file names from the drop down list and click OK.  The Import Captures
form is displayed; click on the Start button.  Selected fields from the incoming
record are displayed on the left hand side of the form and those from the record to
be imported on the right.  Records can be Skipped or Imported by clicking on the
respective buttons.  If IPMR finds an error in the file it will only allow the record to
be skipped or for the Import to be cancelled.  Skipped records are put into a reject
file.  For B-Ring RDF files or CSV if the errors in the reject file are corrected then
it can be re-imported (there should be no errors in submission files).

Warnings will be issued if the capture already exists or if the ringing (as opposed to
a recapture) record exists.  If the imported record is for a dead pullus then IPMR
checks that the date is that if the original ringing record (if any).  These records can
then be imported or skipped.

There are check boxes to allow the Import to continue until an error is found or to
continue to Bypass errors (by automatically skipping them).  These options allow
you to let IPMR continue to import records which is not a particularly rapid
process.

IPMR will try to convert old pre-Data-on-disk codes for some fields e.g. Plumage
code or Sexing Method to the current ones.  User defined code conversions can also
be set up for some fields where you have used your own conventions.  Note that
using the user defined facility can slow down import processing.

Any errors generated during an import into IPMR are saved in a text file and can be
viewed from within IPMR from the Captures > Import menu item.

Creating Submission files
Do this only when you are ready to send a submission to the BTO (or a submission
to your ringing group’s secretary).

Captures Submission files can be created using the Captures > Submissions >
Create function.  Normally you would select “All Outstanding Captures” and click
OK.  All capture records appropriate to be submitted to BTO HQ will be selected
when this function is used. (There is no selection by ring series involved.)

You can enter your e-mail address here.  This will be used in the future by the
Ringing Unit to email recovery details back to you.

Make a note of the name and location of of the submission file which will be
displayed in a message box.  This file should be emailed to ringing.data@bto.org
(or if you have no email) put on a diskette and posted to The Nunnery.

Entering information received from BTO HQ
When the Ringing Unit sends details of a recovery of one of your ringed birds or
first ringing details for a control that you have sent in you can enter these details
into IPMR.  This enables a full capture history to be maintained.  There are Capture
menu options for ‘Enter recoveries’ and ‘Control First Ringing details’.  These ask
for the ring number, which is checked before a capture details entry form is
presented.  Before entering the capture details the Place details will need to be
added.  These can be added using the standard Places facility, but in order to keep
details of your places separate from those of others and to allow the use of a
simpler form the Control > Places  > Others’ Places menu option should be used.
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When using the Recoveries function the Record Type will have been set to C
(Control) by default in the Captures form.  However, if the bird has been recovered
by a non-ringer, is a local control i.e.  a retrap, is dead or has been observed as a
field sighting then the record type will need to be changed.  Fields such as the
species and ring number will have been completed.  The other fields should be
completed as normal.

Others’ Ring Series
Reference details can be held of ring series used by other ringers.  It is particularly
useful for storing ring series of local ringers with whom you might swap controls.
There is a facility to import Others’ ring series information from a file that can be
generated from the Ring Series form of another IPMR user’s database.

Confidential Sites
The places function has a check box to indicate that a place is confidential.  When
the check box is selected the open details can be entered with a greater coordinate
(in)accuracy figure of up to 99 km.  The fields to contain the secure details are
displayed and can, optionally, be entered. 

The data on disk submissions are created using the open place details.  Printed
Ringing schedules can be created using the confidential information.  These are
made on the basis of the sets of records in the data on disk submissions and are
managed from the Captures/ Submission menu items.

Location details for secure places can be kept in the database in encoded form with
the use of a password.  To do this use menu item Control > Places > Set Secure
Place Password. (It can be unset again by entering a blank new password.)

Working with Capture records held in IPMR

Analyse your data

Select your records: The Captures > Capture Selection and Processing function
allows records to be selected by record type, species, ring series or number, date
and/or submission status (or many other fields using the SQL facility).  Once
the selection criteria have been entered by filling in one of the fields at the top
of the form e.g. a date, a species and/or a place code, the ‘Run Query’ button
should be clicked.  The set of records that meet the criteria are then displayed.
To get data for a retrapped bird enter the ring number and all of the record for
that bird will be displayed.

View capture details: The details of the record(s) can be viewed or edited by
selecting a record and clicking the ‘Edit Capture Record’ button.  If the record
has already been submitted a warning message will be displayed; if the record is
then updated it can be flagged for resubmission by clicking on the warning
message.

Standard reports: Capture history and capture details reports can be produced for
the selected records. 

Export data: An export function allows the selected records to be written to a
comma-delimited file.

Tabulation queries: Using the Report > Cross-tabulation menu item cross-
tabulations can be generated into a report.  This is a powerful reporting facility
allowing you to report on say counts or averages of one field tabulated by up to
two others.  For example you could compare average weights by site by month
of the year.  In this case you could have already selected by species using the
selection query.  The cross-tabulation is saved as a query that can be used by the
Report Manager or to be exported into a file that you can put into a spreadsheet,
for instance.

Recoveries Reporting: If you select a set of birds, based on either original ring
details, recovery details or just place involved then any recoveries that those 
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birds are involved in can be shown in a report or the information can be
exported.

Other Ringing Reports
Click on Captures > Reporting. There are a selection of reports available.  Select
one to try by clicking on the menu item.  On the criteria selection form specify a
criterion and click on OK.  The report will appear on the screen and you can page
through it using thearrows in the bottom left corner of the screen.  To print a report
select File > Print from the menu when the report is displayed.
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Nest Recording

Nest Subsites can be
     Specific
         or
     General

Nest Subsites
Subsites can be used in two ways.  It is important to understand these:

1) It can hold information for Specific nests sites.  These might include
Peregrine eyries or Dipper nests in the same spot under a bridge.  They are
somewhat analogous to Nest Boxes, but obviously have quite different
characteristics.

2) It can hold General habitat and other nest information that can be used to set
default values when you set up a Nest Record.  This can be useful at
colonies or for regularly used sites with common habitat.  The alternative is
to enter the habitat information individually for each Nest Record.

Go to Control > Nest Subsites.  You will be presented with a list style form in
which you can enter subsites for any of your Places.  Select the place code from the
drop down list and then enter a subsite code and name.  Clicking on the Subsite
Details button will display the detailed information for that subsite.

 
Nestbox Types

This is the
information that the
BTO want to know
about your Nest
Boxes

If a nest is recorded as being a Nest Box then a Nest Box type must be associated
with it.  This includes information on the style of box and its size.  Generally you
will have a set of Nest Box types.  You will typically have a number of Nest Boxes
that have the same Nest Box Type.  A number of Nestbox Types are shipped as a
starter set with IPMR; these are based on those in the BTO Nestbox Guide. 

Go to menu item Control > Box Types you will be presented with a list style form,
similar to that for Nest Subsites, in which you can enter new Nest Box types.
Clicking on the Box Type Details button will display the detailed information.

Nest Boxes

This is the
information that you
may want to hold
about your Nest
Boxes

Nest Boxes are associated with a Place.  Each will have a code and must have an
associated Nestbox Type.  If you use numeric Nest Box codes then it is suggested
that you use leading zeroes, e.g. 011 rather than 11 (see below).  Usually you will
also associate a Subsite to store habitat information.  There are a number of other
attributes that you can hold for a Nest Box.  It is recommended that you complete
the Walk Order which, when you select the Nest Box for a Nest record, the box’s
walk order is used to set the Nest Finding field in a nest record.  The Nest Finding
field is used to sort active nests for some IPMR reports.  As for Nest Box codes if
you want to use numbers for the walk order then you should use leading zeroes in
order for the sort to operate as you want (as it sorts by characters, not by number
value).  Other information such as Nest Box height, etc, may also be recorded.

Rapidly enter your
Nest Box details

It is recommended that you add all of the Nest Box codes for a Place using the Nest
Box list form.  Once these have been entered go to the top of the list and click on
the Box Details button.  This will show the details about the box.  You can navigate
back and forward through the list of boxes for that Place using the ‘Next Box’ and
‘Previous’ buttons.  If you double click on any of the fields the background colour
will turn yellow and any values held in that field will be transferred to the next box
you go to assuming that the field(s) involved are empty in the next box’s details (it
will not overwrite any information!).

You can change
Nest Box details
between years

If you move a Nest Box between seasons then you can retain the Nest Box code if
you wish.  The Nest Box details required by BTO HQ for a nest are copied to and
held in the Nest record.  This means that changing the Nest Box details will not
affect previously entered nests.
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Creating Nests
Nest records are entered initially from the Nest Recording > New Nests menu item.

When entering a new nest you should normally enter the Species concerned first.  If
this is not know initially then leave the Species field blank.  The Place code and
habitat codes are mandatory and must be completed before entering any visits
information.  Having entered the Place code the drop down lists of Subsites and/or
Nest Boxes available will be populated with any you have set up for that Place.
The grid reference will be a four figure grid reference (from the Place details) with
hyphens in place of the third and sixth figures from a six figure grid reference.  If
you can please add these missing digits to increase the accuracy and value of the
data.  Nest Subsites or boxes can have six figure grid references entered in their
details and these will be used in the nest record.

Make use of the
default values held
for your place,
subsite or box.

Upon entering a subsite or a box with an attached subsite many of the fields in the
Nest Record will be automatically filled if default values have been set up for them
(they can then be overridden, if required, for this individual nest).  The values, of
course, can be entered for any of these fields manually without using subsite or
Nest Box codes.  Generally the fields on the form should be self explanatory with
the aid of the BTO’s Nest Recording handbook.

Nest Site details, if not already added from the subsite details, can be entered by
selecting entries from the drop down lists or the blue Nest Site details button can be
clicked; this will present a new form from which the entries required can be
selected.

Habitat details must be entered for at least one habitat for the first two levels of
coding e.g. “B1: Scrubland (or very young  - Regenerating natural or semi-natural
woodland”. Three further habitats can be entered if required. Also levels 3 and 4 of
habitat description can be entered onto a pop-up form by clicking on the blue
buttons adjacent to the habitat codes.

The Shared Nest button should only be used where, for example, a blue tit and a
great tit both lay eggs into the same clutch of eggs.  This should NOT be used when
a nest is reused either by a different species displacing the original nesting attempt
or where a pair lays a second clutch.  In the latter case the pair code and brood
number should be entered (see Help for further details).

The Finding Information field has a dual role. One is to allow you to enter some
information that is useful in relocating a nest, but it is also used in a number of
instances to sort the nest records into an order. Therefore it should be entered with
some data that means that when sorted it will be in a sequence that is useful to you
e.g. a walk order of nests (e.g. PM/001) or distance along a beach (e.g. 0050m).

The nest details shouldn’t need to be changed, as it will be Nest Visits that will be
updated from now on, but the Edit Nest menu option allows this, if required.

If details are being entered for a number of new nests then the use of the auto repeat
function can save much time.  Most of the fields for the form can use this facility.
To turn it on or off the mouse should be “double clicked” on each field.  The
background colour will change to a pale yellow colour when auto repeat is on.

Entering visits
Once you have entered the Nest Record details you can then use the nest visits
form.

Visit information such as date, time, nest contents and status codes can be entered
directly for each nest visit.  Status codes can be typed in directly, selected from a
drop down list (based on the state of the nest) or via a selection panel.  The
selection panel is displayed by clicking the Status Codes Selection button.

The Nest Visits entry form can be invoked from a number of places in IPMR
depending on what you want to do and how you want to use IPMR. 
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Update nest visit
information for the
set of nests that is
convenient for you

• If you come from the Nest Record Card form using the Visits button then
you can look at only the one nest.

• If you use the Edit Visits menu item then you will have the full set of
nests that IPMR holds.

• If you use the Edit Outstanding Visits menu item (this would be the most
common way) then you will have all nests for which an outcome code
has not been added.  The order of nests in this case is determined
primarily by sorting on the content of the Nest Finding/Comments field.

  • If you come from the Nest Selection and Processing form then you will
have the set of Nests that you have selected available to you.  This can be
by Place code, Nest Box, Year, etc.

   You can either select all nests or outstanding nests to edit and you can scroll
through the nests using the Next and Previous buttons or use the Goto...  button to
move directly to a specific nest.

   Nests are termed “Outstanding” until the Final outcome code has been entered.
This can be done from either the Nest Record form or the Nest visits form.  In the
latter case if you enter a Status Code for visit that IPMR thinks might be for the last
visit then IPMR will ask whether this is to be used for the Final Outcome code.
Nest Records cannot be submitted unless a Final Outcome code has been added.

   Other information can be entered for a visit.  This includes egg measurements,
chick measurements and ringing details (see below) and adult capture details.
These are accessed via buttons on the bottom of the form.  The buttons are only
displayed when the nest has appropriate contents e.g. some eggs for the Egg Details
button.  To enter adult captures the Adult trapped status code must be entered first.
See the Help system for a description of how to enter these details.

  
 Nest statistics

 
IPMR estimates the
nest statistics when
you enter a final
outcome code for the
nest

  There are other fields held in the nest record that can be updated from the visits
form.  These are the first egg and pulli dates, fledging dates and pulli-fledged fields.
These are not submitted to BTO HQ, but will be useful for any of your own
analyses.  IPMR will try to estimate these figures for you when you enter a final
outcome for the nest, but you can enter or substitute your own values at any time.
The figure for the first pullus date is used for the Pulli Checking report, which lists
nests at which there may be ringable young on a given (your next planned visit)
date.

  
 Ringing details for nestlings

   When the Young Ringed status code and a status code equal to one of the ringing
scheme’s pullus codes e.g. IP or FM, has been entered and the Chick Handling
button is pressed then you will have a message prompt asking whether you want to
enter the batch of ringing details together (by specifying first ring and the number
of pulli ringed).  

 The alternative is to enter the birds separately in order to add measurement details
etc.

This information is held in the Captures part of the database and handled for
reporting and submission purposes as normal there for ringing, but the details are
also included with the Nest Record submission so even if you are not a ringer
yourself the if your birds are ringed then please set up some ringer details in the
Owner information and add the capture information.

One thing to note is the use of the ‘P’ record type.  This is used for pulli that die
before fledging.  A pullus must only have one capture record submitted to BTO
HQ, which if the bird dies in the nest should be a record type P.  If you enter a
young dead status code for a visit and there have been young ringed then you will
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be offered options to convert the record types of these birds from N to P.

  
 Creating a Nest Records submission
 Do this only when you are ready to send a submission to the BTO.

 Nest Record Submission files can be created using the Nest Records > Submissions
> Create Submission File function.  Normally you would select “All Outstanding
Nests” and click OK.  All nest, visit, egg and capture records appropriate to be
submitted to BTO HQ will be selected when this function is used. (The capture
information is a subset of that submitted by the Captures Submission function.
Capture Submissions must be sent in independently of Nest Record Submissions.)

  
 Working with Nest records held in IPMR

   The Nest Selection and Processing function allows nest records to be selected by
place, species, year, subsite, box code or submission number.  Once the selection
criteria have been entered the ‘Run Query’ button should be clicked.  The set of
records that meet the criteria are then displayed. 

 View or edit Nests,
Visits or the
Captures from a
selected set of nests

 

 

 

 

 

 Analyse your data

  Nest details: The selected nests can be viewed or updated by double-clicking a
record, pressing the View button or Choosing the Edit/Edit Record menu item;
the first nest displayed will be the nest that is selected in the list.  If the record
has already been submitted a warning button displayed.  If the button is clicked
it will be flagged for resubmission.

 Visit Details: The Visits of all selected records (starting with those for the
selected nest) can be edited by clicking on the View Visits button

 Capture selection: The Captures associated with the selected nest can be
viewed by clicking on the View Captures button.  This function uses a modified
version of the Capture Selection and Processing form

 Export data: An export function allows the selected records to be written to a
comma-delimited file.  The fields exported can be selected from a menu option. 

 Tabulation queries: Using the Report menu item cross-tabulations can be
generated into a report.  This is a powerful reporting facility allowing you to
report on say counts or averages of one field tabulated by up to two others.  The
cross-tabulation is saved as a query that can be used by the Report Manager or
to be exported into a file that you can put into a spreadsheet, for instance.

 On-line help
             Clicking the blue Help button found at the top right of all IPMR forms or pressing

F1 from within IPMR will take you into the on-line help relevant to the screen that
you are using.  The Help menu options to start from the Contents page or the help
Search facility can be used.
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 System Requirements and Installation
  IPMR requires a Windows 3.1 or Windows 95/98/NT/2000 based PC.  IPMR has

been designed for a screen resolution of 800x600, which is normal for SVGA;
lower (or higher) resolutions can be used.  The minimum configuration is a
120MHz Pentium processor with 16MB RAM, but 233MHz with 32MB RAM is
recommended.  Higher specification PCs are recommended particularly if the
database is to hold large numbers of records i.e. greater than 50,000.  The
maximum size of database will depend on processor speed, the amount of memory
installed and the patience of the operator, but many more than 100,000 must be
considered carefully.  The initial installation requires about 15MB of disk space.

 

CD install
 There is a single installation CD. Full instructions accompany the CD.

 

Web Site Download install
 To download the Complete IPMR System use the Complete IPMR System link
available from the BTO web site that can currently be found at http://www.bto.org.
This should then give you an option to save the file.  You should set the saving
location to be an independent directory such as c:\download.

 You should then Open (execute) the downloaded file.  This can be done from File
Manager or Windows Explorer.  The downloaded file can be found in the download
directory e.g. c:\download.  Then using the mouse you can either double-click the
file name or click the right-hand button the file name and select Open from the
shortcut menu.  You should take the option to overwrite any existing files.  The
extraction should also be to your download directory e.g. c:\download or a
temporary directory e.g. c:\temp

 You should then run the setup program e.g. c:\download \setup.exe

 

Setup
  The installation program provides guidance on the install process and allows for the

selection of a target directory for the IPMR application. 

  After IPMR is installed the IPMR Installation and Maintenance program is
automatically started.  At this time the folders or directories that IPMR uses for its
databases and input and output files can be changed.  By default your database will
be put into C:\IPMR\DATA.  The Data directory/folder must be a different
directory from the application directory selected earlier in the install process; it can
only be moved (e.g. putting it in another drive, such as D:\IPMR\DATA) using the
IPMR Installation and Maintenance program.

  IPMR’s other options can be entered at this point using the IPMR Installation and
Maintenance program or they can be set later using the Options function within
IPMR.  Use File/Exit from the menu to exit IPMR Installation and Maintenance.

 

After Installation
  There are two program icons generated by the install process:

 • IPM Reporter is used to start IPMR.

 • IPMR Installation and Maintenance is used if the databases need to
be moved to a new data directory, to upgrade databases to a new
version or if they become corrupted.
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Upgrading IPMR
Upgrades to IPMR are distributed using ZIPed files.  These are available from the
BTO Web site that can currently be found at http://www.bto.org.  To download the
new IPMR release click on the Latest release link.  This will give an option to save
the file.  Set the saving location to Desktop.

You should then Open (execute) the downloaded file by double-clicking on the
file’s icon on the Windows Desktop.  You should take the option on the PKSFX
window to overwrite the existing application files.

The IPMR upgrade must be installed into the IPMR Application directory.  This
was selected when IPMR was first installed and is c:\ipmr by default.

You MUST then reboot Windows otherwise IPMR may not function correctly
and any database upgrade may fail.

If you have been using a previous version of IPMR then any databases may need to
be upgraded.  First ensure that you have a backup of the database file in case
problems occur.  Then start the IPMR Install and Maintain program.  Under the File
menu item there is an Upgrade option.  This entry should be selected.  This will
present a list of your database(s) from which you should select one and click on the
Upgrade button.  This will then open your database and display a button entitled
“Upgrade to Current Database Version” which should be clicked.  A confirmatory
message will be displayed after the upgrade process.  You should then restart
Windows on your computer before using IPMR.

Re-installing IPMR on a new PC

Before you change the PC
If you are planning to change PC then you should backup copies of your
database(s) and also IPMR20.REF.  The databases can be found in the Data Path
set in the Options form (by default this is c:\ipmr\data\).  IPMR20.REF is held in
the Application Path (c:\ipmr by default).

Re-installing IPMR
IPMR should be installed from CD or Web download as normal.  Before running
the setup.exe program create the c:\ipmr and c:\ipmr\data directories.  Copy your
databases back to c:\ipmr\data and IPMR20.REF to c:\ipmr.  Then run the setup
program.
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Integration with your own copy of Microsoft Access

Why use your own copy of Microsoft Access ?
In order to allow you to use all of the features and functions of IPMR mentioned in
this guide a run-time version of Access is installed when IPMR is installed.  If you
have your own copy of Access at versions 2, 95, 97 or later then you can use it for
analysis and reporting functions that are not provided by IPMR already and you
prefer to use Access compared with Report Manager. 

Access is a powerful tool and without care data can be lost or damaged, just like
you can accidentally delete or corrupt data in a spreadsheet.  Consequently, it is
recommended that initially you learn to use Access on a copy of your IPMR data
rather than the original (see below).

How to integrate Access with IPMR by taking a copy of
the database objects
These instructions assume that you are familiar with Access. They assume Access
97, but other versions are similar.

1. Create a new database using File > New database

2. Import your data tables from you own IPMR database using File > Get External
Data > Import; Select your IPMR database (from c:\ipmr\data by default) with
the file type as Microsoft Access Database; select the ‘Tables’ tab and click on
‘Select All’ and then ‘Import’

3. Import the reference tables from the IPMR reference database using File > Get
External Data > Import; Select the IPMR Reference database called
IPMRREF.MDB (from c:\ipmr\) with the file type as Microsoft Access
Database; select the ‘Tables’ tab and click on ‘Select All’ and then ‘Import’

4. Optionally, import the queries from the IPMR application database using File >
Get External Data > Import; Select the IPMR Reference database called
IPMR20.MDB (from c:\ipmr\) with the file type as Microsoft Access Database;
select the ‘Queries’ tab and select either all or selected queries and then click
‘Import’.  A starter set of IPMR’s queries (you can always add more later) is:

Q_captures

Q_CapturesDetail

Q_CaptRecoveries

Q_NR_summary

Q_NRCVisits_Export

Q_NRCBox_Export

Any cross tabulation queries you have created

Use File > View Table Relationships from within IPMR to assist in the definition
of new cross table queries.
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How to integrate Access with IPMR by attaching
database objects from within IPMR databases
These instructions assume that you are familiar with Access. They assume Access
97, but other versions are similar.

1. Create a new database using File > New database

2. Attach your data tables from you own IPMR database using File > Get External
Data > Attach; Select your IPMR database (from c:\ipmr\data by default) with
the file type as Microsoft Access Database; select the ‘Tables’ tab and click on
‘Select All’ and then ‘Attach’

3. Attach the reference tables from the IPMR reference database using File > Get
External Data > Attach; Select the IPMR Reference database called
IPMRREF.MDB (from c:\ipmr\) with the file type as Microsoft Access
Database; select the ‘Tables’ tab and click on ‘Select All’ and then ‘Attach’

4. Optionally, import the queries from the IPMR application database using File >
Get External Data > Import; Select the IPMR Reference database called
IPMR20.MDB (from c:\ipmr\) with the file type as Microsoft Access Database;
select the ‘Queries’ tab and select either all or selected queries and then click
‘Import’.  A starter set of IPMR’s queries (you can always add more later) is:

Q_captures

Q_CapturesDetail

Q_CaptRecoveries

Q_NR_summary

Q_NRCVisits_Export

Q_NRCBox_Export

Any cross tabulation queries you have created

Use File > View Table Relationships from within IPMR to assist in the definition
of new cross table queries.
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